Artigos recentes

Navigation

Progressão aritmética [P.A.] e Progressão geométrica [P.G.]

Planilha eletrônica confeccionada no Excel, sobre Progressão Aritmética e Progressão Geométrica.
Após algumas atualizações e ter criado uma planilha no Excel para tratar de funções polinomiais do segundo grau com uma incógnita, resolvi continuar o padrão de posts relacionados à planilhas eletrônicas. Então segue mais esta postagem, agora tratando de Progressão Aritmética (PA) e Progressão Geométrica (PG).

Progressão aritmética [P.A.] e Progressão geométrica [P.G.]

PA e PG são conteúdos comumente estudados no ensino médio e que lidam com sequências numéricas. A PA é uma sequência numérica em que cada termo, a partir do segundo, é igual ao anterior somado com o número fixo, dito razão desta progressão. A PG é uma sequência de números não nulos em que cada termo posterior, a partir do segundo, é igual ao anterior multiplicado por um número fixo dito razão desta progressão.

Os gráficos gerados dos números da sequência de uma PA ou de uma PG têm aparência com a logo deste post. Existem inúmeras questões a respeito destes conteúdos que demandam interpretação das situações propostas, para além dos cálculos em fórmulas como apresenta a planilha.

Estes conteúdos têm aplicações em diversas áreas, por exemplo, na Biologia com a reprodução das bactérias;  ou em Química, no balanceamento e na proporção de fusão de elementos, na Economia, com crescimentos ou decrescimentos constantes ou variáveis ou com juros simples e juros compostos; ou seja, situações que envolvem sequências numéricas.

A planilha aborda alguns cálculos relacionados à PA e à PG, o mais importante está na leitura, no entendimento e na aplicação destes conteúdos. Os cálculos são básicos e até repetitivos quando estudados na escola. Está planilha então serve para verificar os cálculos realizados. Trabalhar a implementação desta planilha é até interessante, mas demandaria outras implementações para explorar mais o conteúdo. Mesmo assim, apresento as funcionalidades da planilha, bem como o modo em que a implementei.

Funcionalidades da Planilha

Progressão aritmética [P.A.] e Progressão geométrica [P.G.]

As funcionalidades da planilha já são aparentes na imagens. São realizados 6 diferentes resultados para a PA e para a PG:
# enésimo termo;
# primeiro termo;
# razão (r, q);
# número de termos (n);
# soma dos n termos (S);
# 10 primeiros termos.

Apesar das legendas indicarem "Cálculo" os valores obtidos na verdade são apenas resultados, já que os cálculos estão ocultos nas fórmulas. Estas fórmulas são apresentadas detalhadamente mais abaixo, tanto no formato algébrico, quanto no formato lógico-matemático (codificação Excel).

Como criei a planilha [PA e PG]


Progressão aritmética [P.A.] e Progressão geométrica [P.G.]

A inserção dos dados conhecidos


Os únicos espaços disponíveis para inserção de dados são as células em amarelo. É informado que se deve inserir os valores conhecidos. Comumente, haverão três dos 4 valores conhecidos e o quarto valor, assim como os já inseridos irão aparecer como resultados dos cálculos. Na planilha construída, as células que referenciam cada item são:
r = C6 (razão)
a= D6 (primeiro termo da sequência)
n = E6 (número de termos)
an = F6 (último termo determinado, enésimo termo)

Cálculo do termo an da PA (enésimo termo, termo geral)


A codificação no Excel: =SE(E6="";"";SE(D6="";"";SE(C6="";"";D6+(E6-1)*C6)))
A fórmula matemática: $a_n = a_1 + (n - 1) \cdot r$


Cálculo do termo a1 da PA


A codificação no Excel: =SE(C6="";"";SE(E6="";"";SE(F6="";"";F6-(E6-1)*C6)))
A fórmula matemática é a mesma  do termo geral, mas evidenciando o primeiro termo: $a_1=a_n - (n - 1) \cdot r$

Cálculo da razão (r) da PA


A codificação no Excel: =SE(E6="";"";SE(E6=1;"";SE(D6="";"";SE(F6="";"";(F6-D6)/(E6-1)))))
A fórmula matemática: $r = \cfrac{a_n - a_1}{n - 1}$
Observe que temos uma observação, não pode ocorrer $n = 1$, como $n - 1$ é denominador, teríamos 0 (zero), e isso não pode ocorrer. Para que não tenhamos uma mensagem de erro, na codificação foi implementado retorno vazio quando $n = 1$.


Cálculo do número de termos (n) da PA


A codificação no Excel: =SE(C6="";"";SE(C6=0;"";SE(D6="";"";SE(F6="";"";1+(F6-D6)/C6))))
A fórmula matemática: $n = 1 + \cfrac{a_n - a_1}{r}$
Apesar de poder existir sequências constantes na P.A., ou seja, $r = 0$, na implementação da fórmula para a codificação, observe que r não pode ser $0$ (zero), pois está no denominador; para não haver mensagem de erro, implementamos retorno vazio quando $r = 0$.


Cálculo da soma dos n termos da PA

A codificação no Excel: =SE(E6="";"";SE(F6="";"";SE(D6="";"";((D6+F6)*E6)/2)))
A fórmula matemática: $S_n = \cfrac{(a_1 + a_n) \cdot n}{2}$


Os 10 primeiros termos da PA


A codificação no Excel:
=SE(C11="";"";C11), primeiro termo.
=SE(C11="";"";SE(C6="";"";C23+C6)), segundo termo.
(...)
As demais são semelhantes a esta última codificação e alterando a célula C23, pela célula do termo anterior.

A fórmula matemática:
$a_1$
$a_n = a_{n-1} + r$

Progressão aritmética [P.A.] e Progressão geométrica [P.G.]

A inserção dos dados conhecidos


Na planilha construída, as células que referenciam cada item são:
$q$ = L6 (razão)
$a_1$ = M6 (primeiro termo da sequência)
$n$ = N6 (número de termos)
$a_n$ = O6 (último termo determinado, enésimo termo)


Cálculo do termo an (enésimo termo) da PG


A codificação no Excel: =SE(N6="";"";SE(L6="";"";SE(M6="";"";M6*(L6^(N6-1)))))

A fórmula matemática: $a_n = a_1 \cdot q^{n-1}$


Cálculo do termo a1 da PG


A codificação no Excel: =SE(N6="";"";SE(L6="";"";SE(O6="";"";O6/(L6^(N6-1)))))

A fórmula matemática: $a_1= \cfrac{a_n}{q^{n-1}}$


Cálculo da razão (q) da PG


A codificação no Excel: =SE(M6=0;"";SE(N6="";"";SE(N6=1;"";SE(M6="";"";SE(O6="";"";(O6/M6)^(1/(N6-1)))))))
A fórmula matemática: $q = \sqrt [ n-1 ]{\cfrac{a_n}{a_1}  } $ ou $q = \left( \cfrac{a_n}{a_1} \right)^{\cfrac{1}{n-1}} $

A codificação foi realizada baseando-se na fórmula escrita no segundo formato, por desconhecer a implementação de raízes com radicais superiores a 2. Observe que poderíamos ter algum problema por haver divisão e a1 não poderia assumir 0 (zero) pela fórmula, mas isso é garantido pela definição de P.G., já que ela não pode ser nula.

Teremos um problema se n = 1, ou seja, se quisermos apenas um elemento, observe na fórmula que usamos n - 1 no denominador, ou é, se n = 1 teríamos zero no denominador, o que é impossível de resolver; mas veja que não faz muito sentido procurar q para 1 elemento, já que este elemento é o próprio a1. Para não termos esse erro, observe que foi implementado na codificação um retorno vazio para n = 1.


Cálculo do número de termos (n) da PG


A codificação no Excel: =SE(M6=0;"";SE(L6="";"";SE(M6="";"";SE(O6="";"";LOG(IMABS(O6/M6*L6);IMABS(L6))))))
A fórmula matemática: $n = \log _{ \left| q \right|  }{ \left| \left( \cfrac { { a }_{ n } }{ { a }_{ 1 } \cdot q }  \right)  \right|  }  $
Um destaque especial para esta fórmula, a presença dos dois módulos se deve ao não cálculo de logaritmo para números negativos, já que a razão aqui não é nula (q é diferente de zero pela definição de P.G.), mas pode ser negativa.


Cálculo da soma dos n termos da PG


A codificação no Excel: =SE(N6="";"";SE(M6="";"";SE(L6="";"";(M6*((L6^N6)-1))/(L6-1))))

A fórmula matemática: $S_n = \cfrac{a_1 \cdot (q^n-1)}{q - 1}$


Os 10 primeiros termos da PG


A codificação no Excel:
=SE(L11="";"";M6)
=SE(L11="";"";SE(L6="";"";M6*L6))

A fórmula matemática:
$a_1$
$a_n= a_{n-1} \cdot q$

Download


A planilha está disponível para download a partir dos servidores abaixo. Caso queira editar, implementar ou conferir algumas funções da planilha, a senha de desbloqueio é a sequência de 1 a 6.
  • Arquivo originado em: Microsoft Office Excel 2010.

Google Drive
Google Drive
Box
Box
Acesse outras planilhas no Excel neste blog.


Referência e recomendação


GIOVANNI, José Ruy. Matemática Fundamental. Editora FTD. São Paulo, 1994.

Após terminar este post, resolvi procurar planilhas sobre P.A. e P.G., encontrei uma que realiza mais funções que a que disponibilizo, mas apenas para P.A.. Vale a pena conferir no Blog Matemática na Veia.

Charles Bastos

Comente este artigo:

8 comentários:

  1. Olá, Charles!

    Ótima planilha. Gostei muito mesmo.

    Abraço!

    ResponderExcluir
    Respostas
    1. Olá Edigley...
      Muito obrigado pela divulgação do post. Que bom que você gostou da planilha!

      Excluir
  2. Olá Xarlles, bom dia!

    Parabéns, seu blogue tá show de bola! As informações estão bem organizadas e com uma apresentção de abertura muito "limpa" e rápida!

    Forte abraço,

    Irivan Rodrigues

    ResponderExcluir
    Respostas
    1. Olá!
      Muito obrigado pela visita e por divulgar o blog Irivan!

      Excluir
  3. muito bom mesmo. parabéns por disponibilizar a todos.
    tentei fazer mas me compliquei na hora dos expoentes.
    obrigado!

    ResponderExcluir
    Respostas
    1. Que bom que você gostou Elizandro. Quando fui organizar, fiquei pensando em como organizaria a questão de expoentes também... mas logo consegui uma solução.

      obrigado por visitar o blog! Vote sempre...

      Excluir
  4. Olá meu querido. Gostei muito do blog, sua planilha ficou muito show. Vou utiliza-la em minhas aulas. Valeu
    www . matematicacritica.blogspot.com

    ResponderExcluir
    Respostas
    1. Que bom que você gostou do blog! Volte sempre...

      Excluir