Artigos recentes

Navigation

Planilha no Excel sobre sistemas lineares com 3 equações e 3 incógnitas

Planilha eletrônica sobre sistemas lineares com 3 equações e 3 incógnitas.
Em mais um post com planilha eletrônica, que apresenta a solução de sistemas de equações do primeiro grau com três incógnitas e três equações e para isso, resolvemos utilizar a regra de Cramer, que é um método para se resolver um sistema linear.

Planilha no Excel sobre sistemas lineares com 3 equações e 3 incógnitas

Apresentamos aqui, um pouco sobre tal regra que utiliza determinantes para expressar possíveis soluções de sistemas lineares, a codificação na planilha ao encontrar a solução e classificar o sistema e a planilha para download.

Não perca a Coleção de Planilhas no Excel na página de downloads do blog!

Regra de Cramer

Não iremos generalizar a regra de Cramer; apenas nos limitaremos apresentá-la para o caso de um sistema de equações do primeiro grau com três equações e três incógnitas, assim como foi utilizada para codificar a planilha eletrônica disponibilizada neste post.

O sistema:
$\begin{cases} ax+by+cz=d \\ fx+gy+hz=k \\ px+qy+rz=s \end{cases}$

A regra:
O sistema anterior pode ser expresso da seguinte forma:
$\begin{bmatrix} a & b & c \\ f & g & h \\ p & q & r \end{bmatrix}\cdot \begin{bmatrix} x \\ y \\ z \end{bmatrix}=\begin{bmatrix} d \\ k \\ s \end{bmatrix}$

Aplicando a Regra de Cramer temos:
$x=\frac { det\quad{A}_{ x } }{ det\quad A } $,

$y=\frac { det\quad{A}_{ y } }{ det\quad A } $ e

$z=\frac { det\quad{A}_{ z } }{ det\quad A } $


Em que
$A=\begin{bmatrix} a & b & c \\ f & g & h \\ p & q & r \end{bmatrix}$ é a matriz incompleta do sistema.

${ A }_{ x }=\begin{bmatrix} d & b & c \\ k & g & h \\ s & q & r \end{bmatrix}$, ${ A }_{ y }=\begin{bmatrix} a & d & c \\ f & k & h \\ p & s & r \end{bmatrix}$ e ${ A }_{ z }=\begin{bmatrix} a & b & d \\ f & g & k \\ p & q & s \end{bmatrix}$, são as matrizes obtidas de $A$ substituindo-se as colunas dos coeficientes de $x$, $y$ e $z$ pela coluna dos termos independentes ($d$, $k$ e $s$).

Funcionalidades na Planilha

A planilha realiza as funcionalidades:
# Especifica local para os números $a$, $b$, $c$, $d$, $f$, $g$, $h$, $k$, $p$, $q$, $r$ e $s$ nas equações;
# Encontra, caso exista, a solução do sistema;
# Indica se o sistema possui infinitas soluções, uma ou nenhuma;
# Classifica o sistema em $SPD$ (sistema possível e determinado), $SPI$ (sistema possível e indeterminado) ou $SI$ (sistema impossível).

Os códigos Excel na planilha


Planilha no Excel sobre sistemas lineares com 3 equações e 3 incógnitas


Os resultados dos determinantes, da solução e da classificação do sistema só é apresentado, caso todos os campos em amarelo forem preenchidos.

As codificações apresentam alguns poucos tratamentos de erro, como o não preenchimento em caso de inserção de símbolos ou letras nos espaços em amarelo, ou o símbolo "#" para a divisão por zero, que ainda é aproveitado para a codificação na classificação do sistema.

Equações

Os espaços em amarelo indicam os locais em que se devem ser colocados os números $a$, $b$, $c$, $d$, $f$, $g$, $h$, $k$, $p$, $q$, $r$ e $s$, de acordo com o sistema à esquerda (na figura). As únicas células que permitem a inserção de dados são as em amarelo.

Solução

A solução $S = \{x, y, z\}$ é dada a partir do procedimento indicado anteriormente. A codificação de $x$ , $y$ e de $z$ na planilha é dada por:
$x$:
=SEERRO(SE(H12=0;"#";O12/H12);"")

$y$:
=SEERRO(SE(H12=0;"#";T12/H12);"")

$z$:
=SEERRO(SE(H12=0;"#";Y12/H12);"")

Estas três linhas de codificação utilizam codificações anteriores, que calculam os determinantes das matrizes $A$, $A_x$, $A_y$ e $A_z$.
$det A$:
=SEERRO(SE(O6="";"";SE(R6="";"";SE(U6="";"";SE(O7="";"";SE(R7="";"";SE(U7="";"";SE(O8="";"";SE(R8="";"";SE(U8="";"";(O6*R7*U8+R6*U7*O8+U6*O7*R8)-(U6*R7*O8+U7*R8*O6+U8*R6*O7))))))))));"")
$det A = (agr + bhp + cfq) - (cgp + hqa + rbf)$

$det A_x$:
=SEERRO(SE(R6="";"";SE(U6="";"";SE(X6="";"";SE(R7="";"";SE(U7="";"";SE(X7="";"";SE(R8="";"";SE(U8="";"";SE(X8="";"";(X6*R7*U8+R6*U7*X8+U6*X7*R8)-(U6*R7*X8+U7*R8*X6+U8*R6*X7))))))))));"")
$det A_x = (dgr + bhs + ckq) - (cgs + hqd + rbk)$

$det A_y$:
=SEERRO(SE(O6="";"";SE(U6="";"";SE(X6="";"";SE(O7="";"";SE(U7="";"";SE(X7="";"";SE(O8="";"";SE(U8="";"";SE(X8="";"";(O6*X7*U8+X6*U7*O8+U6*O7*X8)-(U6*X7*O8+U7*X8*O6+U8*X6*O7))))))))));"")
$det A_y = (akr + dhp + cfs) - (ckp + hsa + rdf)$

$det A_z$:
=SEERRO(SE(O6="";"";SE(R6="";"";SE(X6="";"";SE(O7="";"";SE(R7="";"";SE(X7="";"";SE(O8="";"";SE(R8="";"";SE(X8="";"";(O6*R7*X8+R6*X7*O8+X6*O7*R8)-(X6*R7*O8+X7*R8*O6+X8*R6*O7))))))))));"")
$det A_z = (ags + bkp + dfq) - (dgp + kqa + sbf)$

Classificação do sistema quanto a solução

Tipo:
(U17="";"";SE(U17="#";SE(O12<>0;"Sistema Impossível";SE(T12<>0; "Sistema Impossível"; SE(Y12<>0; "Sistema Impossível";"Sistema Possível e Indeterminado")));"Sistema Possível e Determinado"))

Quantidade de soluções:
=SE(U17="";"";SE(U21="Sistema Possível e Determinado";"Admite uma única solução!";SE(U21="Sistema Possível e Indeterminado"; "Admite infinitas soluções!"; "Não admite soluções!")))

Temos que um sistema é:

  • possível e determinado, se $det A \neq 0$;
  • possível e indeterminado, se $det A = 0$ e $det A_x = det A_y = det A_z = 0$;
  • impossível, se $det A = 0$ e ao menos um dos determinantes $det A_x$ ou $det A_y$ ou $det A_z$ é diferente de zero.

    Download da planilha

    A planilha está disponível para download a partir dos servidores abaixo. Caso queira editar, implementar ou conferir algumas funções da planilha, a senha de desbloqueio é a sequência de 1 a 6.
    • Arquivo originado em: Microsoft Office Excel 2010.

    Google Drive
    Google Drive
    Box
    Box

    Referência e Recomendações

    [x] GIOVANNI, José Ruy. Matemática Fundamental. Editora FTD. São Paulo, 1994.

    [1] Demonstração da Regra de Cramer. [Blog Fatos Matemáticos]
    [2] Gabriel Cramer. [Site Só Matemática]


    Charles Bastos

    Comente este artigo:

    4 comentários:

    1. Olá, Charles!

      Que ótima e funcional planilha. Já baixei, testei, compartilhei e usarei nas minas próximas aulas.

      Um abraço!

      ResponderExcluir
      Respostas
      1. Olá, Edigley!

        Parecida com a anterior, sobre este tema, agora usando a Regra de Cramer...

        Procurei muito plotar um gráfico R3, mas não consegui e não encontrei artigos a respeito que validassem a interpretação da solução graficamente (dentro da própria planilha).

        Que bom que ela será útil!

        Obrigado por dedicar-se ao Xarlleslb Blog!

        Excluir
    2. esta condição "possível e indeterminado, se detA=0 e detAx=detAy=detAz=0" indica SPI ou SI e não apenas SPI como diz no texto. abraços

      ResponderExcluir
    3. Olá André!
      Para que o sistema seja classificado como possível e indeterminado (SPI) é preciso que o determinante de A seja zero e todos os demais determinantes das outras matrizes também sejam zero.
      Já para que seja impossível (SI), é preciso também que o determinante de A seja zero, mas ao menos um dos demais determinantes das outras matrizes precisa ser diferente de zero; que é justamente o que indica o terceiro item, logo abaixo deste que você questiona.

      [Tais informações estão referenciadas segundo o livro indicado na postagem]

      Obrigado por comentar!

      ResponderExcluir