Artigos recentes

Navigation

Modelo de ficha de autoavaliação preenchida no Excel

Crie planilhas eletrônicas no Excel com o recurso de listas suspensas, como este exemplo de ficha de autoavaliação.
A planilha apresentada nesta postagem, não tem relação com conteúdo matemático, mas apresenta como criar uma lista suspensa para preenchimento de lacunas por meio de alternativas. Uma dica que pode servir para elaboração de atividades, que podem ser respondidas diretamente no computador e que já apresenta resultado. Para isso utilizo um exemplo de uma ficha.

Modelo de ficha de autoavaliação preenchida no Excel


Não sei se a prática de pedir ao aluno que se autoavalie, por meio de fichas ou de uma justificativa ainda é usual entre os professores; mas revendo alguns arquivos meus de quando estudei no ensino básico, encontrei uma ficha que resolvi por reproduzir em forma de planilha no Excel.

Trata-se de uma ficha com 12 competências transversais, cada competência contendo algumas alternativas em que o aluno escolhe aquela que julga mais adequada para ele e depois o professor pontua de acordo com valores prévios estabelecidos; resultando na nota de autoavaliação do aluno.

Competências Transversais


As competências transversais descritas na ficha são:
  • Pontualidade:
    • Fui sempre pontual;
    • Cheguei por vezes atrasado à aula;
    • Cheguei frequentemente atrasado;
  • Assiduidade:
    • Nunca faltei;
    • Faltei a poucas aulas;
    • Faltei a muitas aulas;
  • Comportamento:
    • Cumpri sempre as regras de funcionamento da aula;
    • Cumpri na maior parte das aulas as regras de funcionamento;
    • Perturbei muito o funcionamento das aulas;
    • Perturbei sempre o funcionamento das aulas;
  • Empenho:
    • Fui sempre muito empenhado nas tarefas;
    • Nem sempre fui empenhado nas tarefas;
    • Nunca fui empenhado nas tarefas;
  • Material na aula:
    • Trouxe sempre o material para as aulas;
    • Por vezes não trouxe;
    • Nunca levo o material para as aulas;
  • Atividades de casa:
    • Fiz sempre as atividades de casa;
    • Quase sempre fiz as atividades de casa;
    • Às vezes fiz as atividades de casa;
    • Raramente fiz as atividades de casa;
    • Nunca fiz as atividades de casa;
  • Solidariedade - auxílio ao colega:
    • Fui sempre solidário;
    • Fui solidário às vezes;
    • Nunca fui solidário;
  • Respeitar a opinião dos outros:
    • Respeitei sempre a opinião dos outros;
    • Nem sempre respeitei a opinião dos outros;
    • Nunca respeitei a opinião dos outros;
  • Participação nas atividades de grupo:
    • Participei ativamente nas atividades de grupo;
    • Participei em algumas atividades de grupo;
    • Não participei nas atividades de grupo;
  • Expressão e defesa das minhas opiniões:
    • Expressei e defendi sempre as minhas opiniões com clareza;
    • Expressei e defendi as minhas opiniões, mas, por vezes, com dificuldade;
    • Expressei com clareza mas não defendi corretamente as minhas opiniões;
    • Nunca expressei, nem defendi minhas opiniões com clareza;
  • Superação das dificuldades:
    • Superei sempre as minhas dificuldades;
    • Nem sempre superei as minhas dificuldades;
    • Nunca superei as minhas dificuldades;
  • Autonomia:
    • Fui sempre autônomo nas tarefas;
    • Nem sempre fui autônomo nas tarefas;
    • Nunca fui autônomo nas tarefas;

Lista Suspensa


    Modelo de ficha de autoavaliação preenchida no Excel

    A estruturação da planilha foi realizada da seguinte maneira:

    1) Cria-se a estrutura de bordas como na imagem, deixando os espaços destacados em amarelo, em branco. Estes espaços serão as lacunas em que o usuário deverá clicar para escolher uma das alternativas;

    2) Em uma área não visível da planilha cria-se uma coluna com todas as possíveis alternativas (no caso desta planilha, isso foi realizado na coluna I);

    Modelo de ficha de autoavaliação preenchida no Excel

    3) Clique sobre a primeira lacuna (célula C4). Na aba superior, selecione o item "Dados" e clique em "Validação de Dados";

    Modelo de ficha de autoavaliação preenchida no Excel

    4) Feito isso, aparecerá a tela como na imagem acima. Observe os destaques! Você precisa se certificar de que a célula em que as alternativas irão ficar está selecionada, só depois proceder com a configuração. No espaço "Critério de validação" escolha a opção "Lista" e deixe os itens ao lado marcados. No espaço "Fonte", você deverá selecionar o intervalo de células que farão parte da lista (as alternativas). Para isso basta indicar por exemplo =$I$4:$I$6, que é justamente o intervalo que possui as alternativas para a competência "Pontualidade", observe que foram selecionadas as células I4 até I6 (I4, I5 e I6). Para selecionar você pode proceder de dois modos: digitando o intervalo, como como indicado no exemplo ou com o cursor sobre o espaço "Fonte", clicar sobre a primeira célula sem soltar e arrastar até a última célula do intervalo desejado que o preenchimento é automático.

    5) Repita os procedimentos 3 e 4 para as outras 11 competências.

    6) A definição de pontuação fica a critério do professor, no caso da planilha, os códigos para pontuação foram adicionados nas colunas D e G, respectivamente para cada competência, da seguinte forma:
    =SE(C4=I4;1;SE(C4=I5;0,7;SE(C4=I6;0;"-")))
    =SE(C7=I7;1;SE(C7=I8;0,8;SE(C7=I9;0,2;"-")))
    =SE(C10=I10;3;SE(C10=I11;2,5;SE(C10=I12;0,5;SE(C10=I13;0;"-"))))
    =SE(C14=I14;3;SE(C14=I15;2,2;SE(C14=I16;0;"-")))
    =SE(C17=I17;1;SE(C17=I18;0,6;SE(C17=I19;0;"-")))
    =SE(C20=I20;3;SE(C20=I21;2,5;SE(C20=I22;1,5;SE(C20=I23;0,9;SE(C20=I24;0;"-")))))
    =SE(F4=I25;2;SE(F4=I26;1,5;SE(F4=I27;0;"-")))
    =SE(F7=I28;2;SE(F7=I29;1,2;SE(F7=I30;0;"-")))
    =SE(F10=I31;2;SE(F10=I32;1,2;SE(F10=I33;0;"-")))
    =SE(F13=I34;3;SE(F13=I35;2,3;SE(F13=I36;1;SE(F13=I37;0;"-"))))
    =SE(F17=I38;2;SE(F17=I39;1,5;SE(F17=I40;0;"-")))
    =SE(F20=I41;2;SE(F20=I42;1,5;SE(F20=I43;0,5;"-")))
    Estas 12 linhas de código possuem o mesmo comportamento, comparam a escolha do aluno e atribuem um valor específico preestabelecido, por exemplo nesta última linha os valores foram:
    • Se a escolha foi da alternativa da célula I41, o valor atribuído é 2;
    • Se a escolha foi da alternativa da célula I42, o valor atribuído é 1,5;
    • Se a escolha foi da alternativa da célula I43, o valor atribuído é 0,5;
    • Se nada foi escolhido ainda, no lugar do valor atribuído aparece um hífen;
    7) A mensagem para o resultado e a nota foram configuradas com os códigos:
    =SE(D4="-";I3;SE(D7="-";I3;SE(D10="-";I3;SE(D14="-";I3;SE(D17="-";I3;SE(D20="-";I3;SE(G4="-";I3;SE(G7="-";I3;SE(G10="-";I3;SE(G13="-";I3;SE(G17="-";I3;SE(G20="-";I3;"Sua nota na autoavaliação foi:"))))))))))))
    Isso não permite que a nota seja visualizada parcialmente, mas só após o preenchimento de todas as competências com alguma alternativa.
    e
    =SE(D26="Sua nota na autoavaliação foi:";ARREDONDAR.PARA.BAIXO((SOMA(D4:D20) + SOMA(G4:G22))*0,4;1);"")
    Observe neste código que aparece 0,4:1. O 0,4 é o fator utilizado para multiplicação dos pontos obtidos após a escolha das alternativas e o :1, indica quantas casas decimais irão aparecer no resultado. 
    Modelo de ficha de autoavaliação preenchida no Excel

    O usuário terá apenas que clicar na célula em branco a frente de cada competência e escolher uma das alternativas. Após escolher uma alternativa para as 12 competências, a nota será a soma dos pontos recebidos em cada competência multiplicados por 0,4, totalizando 10,0.

    Download


    A planilha está disponível para download a partir dos servidores abaixo. Caso queira editar, implementar ou conferir algumas funções da planilha, a senha de desbloqueio é a sequência de 1 a 6.
    • Arquivo originado em: Microsoft Office Excel 2010.

    Google Drive
    Google Drive
    Box
    Box

    Espero que tenham gostado desta sugestão de se criar uma lista suspensa para o preenchimento de lacunas. Encontre as outras Planilhas no Excel postadas aqui no blog e confira outras funcionalidades.

    Charles Bastos

    Comente este artigo:

    0 comentários:

    Os comentários neste blog são moderados pelo autor. Leia sobre a política de comentários.