Artigos recentes

Navigation

Planilha no Excel sobre distância entre pontos no plano

Planilha eletrônica (Excel) que simula várias situações a respeito de pontos no plano.
René Descartes (1596-1650), estabeleceu um novo método chamado Geometria com coordenadas ou Geometria analítica, a partir de seu livro La Géometrie. Descartes procurou relacionar as figuras geométricas com elementos algébricos.

Planilha no Excel sobre distância entre pontos no plano

Nesta postagem veremos um pouco a respeito deste método, e contando com o auxílio de mais uma planilha eletrônica confeccionada no Excel. Não se esqueça de conferir nossa coleção de planilhas no Excel!

10 Funcionalidades da Planilha e a Lógica dos Códigos


A planilha foi organizada em 5 blocos, formatada em cores diferentes procurando separar os blocos que têm funções se relacionando em diferentes células. As funcionalidades estruturadas na planilha oportunizam a realização de vários exercícios que podem surgir sobre o conteúdo de distância entre ponto no plano.
Há a possibilidade de apresentar alguns outros blocos, com cálculos relacionados à distância entre pontos, mas como procuro organizar a pasta com uma única planilha e de modo que a área utilizada seja a área visual 100%, poderá em outra oportunidade haver outra postagem, com funcionalidades complementares a esta planilha.
Os gráficos foram organizados de forma dinâmica, ou seja, assim que começam a ser inseridos valores, cada ponto e segmento (que em estado original aparecem sobre o eixo das abscissas) irão assumir um lugar na região gráfica, então, eles estará completo apenas quando todos os em cada bloco forem inseridos. As regiões não foram estruturadas em escalas proporcionais, com isso os eixos apresentarão intervalos diferentes e as inclinações não serão as reais (apesar dos valores nos eixos estarem corretos).
As colunas AP e AQ, colhem os dados de entrada (usuário) e de saída (planilha) que são utilizados para exibir os três gráficos.

São 10, os retornos que esta planilha apresenta, são:

Planilha no Excel sobre distância entre pontos no plano

  • [1] Calcula a distância entre dois pontos $P\left(x, y \right) $ e $Q\left( { x }_{ 1 },{ y }_{ 1 } \right) $, no plano cartesiano; mostrando o gráfico com o segmento $PQ$ que tem os dois pontos com extremos;
Cálculo:
$d\left( P,Q \right) =\sqrt { { \left( { x }_{ 1 }-x \right)  }^{ 2 }+{ \left( { y }_{ 1 }-y \right)  }^{ 2 } } $

Código no Excel:
=SEERRO(SE(G4="";"";SE(F4="";"";SE(D4="";"";SE(C4="";"";RAIZ((F4-C4)^2+(G4-D4)^2)))));"")

Planilha no Excel sobre distância entre pontos no plano

  • [2] Calcula a coordenada de um ponto, a partir da igualdade na medida de dois segmentos $d(P,Q) = d(Q,R)$;
Cálculo:
$d\left( P,Q \right) =d\left( P,R \right)$
$\sqrt { { \left( { x }_{ 1 }-x \right)  }^{ 2 }+{ \left( { y }_{ 1 }-y \right)  }^{ 2 } } =\sqrt { { \left( { x }_{ 2 }-x \right)  }^{ 2 }+{ \left( { y }_{ 2 }-y \right)  }^{ 2 } }$
Então, resumindo:
$x=\frac { { { x }_{ 2 } }^{ 2 }-{ { x }_{ 1 } }^{ 2 }+{ \left( { y }_{ 2 }-y \right)  }^{ 2 }-{ \left( { y }_{ 1 }-y \right)  }^{ 2 } }{ 2\left( { x }_{ 2 }{ -x }_{ 1 } \right)  }$ e  $x=\frac { { { y }_{ 2 } }^{ 2 }-{ { y }_{ 1 } }^{ 2 }+{ \left( { x }_{ 2 }-x \right)  }^{ 2 }-{ \left( x_{ 1 }-x \right)  }^{ 2 } }{ 2\left( { y }_{ 2 }-{ y }_{ 1 } \right)  } $.

Código no Excel:
$x$:
=SEERRO(SE(AA4="";"";SE(Z4="";"";SE(W4="";"";SE(V4="";"";SE(T4="";"";((Z4^2-V4^2+(AA4-T4)^2)-((W4-T4)^2))/(2*(Z4-V4)))))));"")
$y$:
=SEERRO(SE(AA4="";"";SE(Z4="";"";SE(W4="";"";SE(V4="";"";SE(S5="";"";((AA4^2-W4^2+(Z4-S5)^2-(V4-S5)^2)/(2*(AA4-W4))))))));"")

Planilha no Excel sobre distância entre pontos no plano

  • [3] Calcula as distâncias entre os segmentos formados pelos três pontos $P\left(x, y \right) $, $Q\left( { x }_{ 1 },{ y }_{ 1 } \right) $ e $R\left( { x }_{ 2 },{ y }_{ 2 } \right) $, dois a dois,  $d(PQ)$, $d(PR)$ e $d(QR)$;
Cálculo:
$d\left( P,Q \right) =\sqrt { { \left( { x }_{ 1 }-x \right)  }^{ 2 }+{ \left( { y }_{ 1 }-y \right)  }^{ 2 } } $,
$d\left( P,R \right) =\sqrt { { \left( { x }_{ 2 }-x \right)  }^{ 2 }+{ \left( { y }_{ 2 }-y \right)  }^{ 2 } }$ e
$d\left( Q,R \right) =\sqrt { { \left( { x }_{ 2 }-{ x }_{ 1 } \right)  }^{ 2 }+{ \left( { y }_{ 2 }-{ y }_{ 1 } \right)  }^{ 2 } } $

Código no Excel:
$d(PQ)$:
=SEERRO(SE(I11="";"";SE(H11="";"";SE(E11="";"";SE(D11="";"";RAIZ((H11-D11)^2+(I11-E11)^2)))));"")
$d(PR)$:
=SEERRO(SE(M11="";"";SE(L11="";"";SE(E11="";"";SE(D11="";"";RAIZ((L11-D11)^2+(M11-E11)^2)))));"")
$d(QR)$:
=SEERRO(SE(M11="";"";SE(L11="";"";SE(I11="";"";SE(H11="";"";RAIZ((L11-H11)^2+(M11-I11)^2)))));"")

    • [4] Verifica se os três segmentos são lados de um triângulo (ou é, se os três pontos são vértices de um triângulo);
    Verificação:
    $d\left( P,Q \right) < d\left( P,R \right) + d\left( Q,R \right)$,
    $d\left( P,R \right) < d\left( P,Q \right) +d\left( Q,R \right) $
    e $d\left( Q,R \right) < d\left( P,Q \right) +d\left( P,R \right) $
    As três primeiras linhas do código faz a verificação das desigualdades; na quarta linha, havendo validade das três o retorno é de que "Os pontos são vértices de um triângulo!", do contrário "Os pontos não são vértices de um triângulo!".

    Código no Excel:
    =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(C13<(G13+L13);"#";""))))
    =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(G13<(C13+L13);"#";""))))
    =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(L13<(C13+G13);"#";""))))
    =SEERRO(SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(CONT.SE(K15:M15;"#")=3;"Os pontos são vértices de um triângulo!";"Os pontos não são vértices de um triângulo!"))));"")

      • [5] Informa se o triângulo $\Delta PQR$ é escaleno, isósceles ou equilátero - mostrando o gráfico com os três segmentos que podem ou não formar o triângulo.
        • Para o caso, não se formará um triângulo quando os três pontos estiverem alinhados (colineares); ou seja, os três pontos terão o mesmo valor para a abscissa ou para a ordenada, ou ainda, as coordenadas crescem ou decrescem numa mesma constante.
      Verificação:
      $d\left( P,Q \right) =d\left( P,R \right)$
      $d\left( P,Q \right) =d\left( Q,R \right) $
      $d\left( P,R \right) =d\left( Q,R \right) $
      As três primeiras linhas do código verifica se valem as igualdades entre as distâncias. Na quarta linha do código são três os possíveis retornos: Se a contagem das igualdades for 3, significa que todos os lados têm a mesma medida e o retorno é "Equilátero"; se a contagem das igualdades for 1, significa que dois dos lados têm a mesma medida e o retorno é "Isósceles"; se a contagem for nula, o retorno é "Escaleno", pois cada lado terá uma medida diferente da medida do outro. E há ainda a verificação no caso em que os pontos não forem vértice de um triângulo, em que a célula permanece em branco.

      Código no Excel:
      =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(C13=G13;"@";""))))
      =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(C13=L13;"@";""))))
      =SE(L13="";"";SE(G13="";"";SE(C13="";"";SE(G13=L13;"@";""))))
      =SEERRO(SE(C16="Os pontos são vértices de um triângulo!";SE(CONT.SE(G15:I15; "@")=3;"Equilátero";SE(CONT.SE(G15:I15;"@")=1;"Isósceles";"Escaleno"));"");"")


      • [6] Há o acréscimo de uma mensagem no gráfico, que aparece para o caso do triângulo ser retângulo, é exibido no canto inferior direito da área do gráfico destinado a exibir o triângulo $\Delta PQR$;
      Verificação:
      ${ a }^{ 2 }={ b }^{ 2 }+{ c }^{ 2 }$; observando que $a=máx\left\{ d\left( P,Q \right) ,\quad d\left( P,R \right) ,\quad d\left( Q,R \right)  \right\}  $, e que $b$ e $c$ são as outras duas distâncias. Verifica-se a validade da igualdade [Teorema de Pitágoras], em caso afirmativo é feito o retorno de que é "Triângulo Retângulo".

      Código no Excel:
      =SEERRO(SE(MAIOR(C13:L13;1)^2=MAIOR(C13:L13;2)^2 + MAIOR(C13:L13;3)^2; "Triângulo Retângulo";"");"")

        • [7] Podendo formar o triângulo, calcula o comprimento das medianas $d\left(P,{ M }_{ QR } \right)$, $d\left(Q,{ M }_{ PR } \right)$ e $d\left(R,{ M }_{ PQ } \right) $;
        Cálculo:
        $d\left( P,{ M }_{ QR } \right) =\sqrt { { \left( \frac { { x }_{ 1 }+{ x }_{ 2 } }{ 2 } -x \right)  }^{ 2 }+{ \left( \frac { { y }_{ 1 }+{ y }_{ 2 } }{ 2 } -y \right)  }^{ 2 } } $
        $d\left( Q,{ M }_{ PR } \right) =\sqrt { { \left( \frac { x+{ x }_{ 2 } }{ 2 } -{ x }_{ 1 } \right)  }^{ 2 }+{ \left( \frac { y+{ y }_{ 2 } }{ 2 } -{ y }_{ 1 } \right)  }^{ 2 } } $
        $d\left( R,{ M }_{ PQ } \right) =\sqrt { { \left( \frac { x+{ x }_{ 1 } }{ 2 } -{ x }_{ 2 } \right)  }^{ 2 }+{ \left( \frac { y+{ y }_{ 1 } }{ 2 } -{ y }_{ 2 } \right)  }^{ 2 } } $

        Código no Excel:
        $d({M_{PQ})}$:
        =SEERRO(SE(I11="";"";SE(H11="";"";SE(E11="";"";SE(D11="";"";RAIZ((H11-D11)^2+(I11-E11)^2)))));"")
        $d{(M_{PR})}$:
        =SEERRO(SE(M11="";"";SE(L11="";"";SE(E11="";"";SE(D11="";"";RAIZ((L11-D11)^2+(M11-E11)^2)))));"")
        $d{(M_{QR})}$:
        =SEERRO(SE(M11="";"";SE(L11="";"";SE(I11="";"";SE(H11="";"";RAIZ((L11-H11)^2+(M11-I11)^2)))));"")

          • [8] Calcula o baricentro, que é o ponto de encontro das medianas do triângulo $\Delta PQR$, e mostra o ponto $B\left( { x }_{ c },{ y }_{ c } \right) $ no gráfico.
            Cálculo:
            ${ x }_{ c }=\frac { x+{ x }_{ 1 }+{ x }_{ 2 } }{ 3 } $ e ${ y }_{ c }=\frac { y+{ y }_{ 1 }+{ y }_{ 2 } }{ 3 }$

            Código no Excel:
            $x_c$:
            =SEERRO(SE(H18="";"";(D11+H11+L11)/3);"")
            $y_c$:
            =SEERRO(SE(H18="";"";(E11+I11+M11)/3);"")

            Planilha no Excel sobre distância entre pontos no plano

                • [9] Calcula as coordenadas do ponto médio $M\left (a, b \right) $ de um segmento $PQ$ e esboça o gráfico com os três pontos;
                Cálculo:
                $a=\frac { x+{ x }_{ 1 } }{ 2 } $ e $b=\frac { y+{ y }_{ 1 } }{ 2 } $

                Código no Excel:
                $a$:
                =SEERRO(SE(AL4="";"";SE(AH4="";"";(AH4+AL4)/2));"")
                $b$:
                =SEERRO(SE(AM4="";"";SE(AI4="";"";(AI4+AM4)/2));"")

                  Planilha no Excel sobre distância entre pontos no plano

                  • [10] Encontra as coordenadas de um ponto $Q\left( { x }_{ 1 },{ y }_{ 1 } \right) $, sabendo as coordenadas de um ponto $P\left(x, y \right) $ e do ponto médio $M\left (a, b \right) $ do segmento $PQ$. 
                  Cálculo:
                  ${ x }_{ 1 }=2a-x$ e ${ y }_{ 1 }=2b-y$.

                  Código no Excel:
                  $X_1$:
                  =SEERRO(SE(AJ23="";"";SE(AG23="";"";2*AJ23-AG23));"")
                  $Y_1$:
                  =SEERRO(SE(AK23="";"";SE(AH23="";"";2*AK23-AH23));"")


                    É Importante Validar!


                    Quando vou construir as planilhas, procuro por conteúdos que permitem julgar, classificar, identificar, realizar cálculos por meio de fórmulas, e utilizo funções do Excel para que tudo isso se torne um código não visível par ao usuário, justamente pela simples proteção de senha, evitando que ele apague os códigos ocultos nas células.

                    Ao editar uma planilha, penso em que locais devo colocar cada elemento: dados de entrada, dados de saída, formatações condicionais e formatações de organização visual. E durante tudo isso, o mais importante é a validação dos códigos; é preciso testar todas as possibilidades de entrada de dados que o usuário irá fazer e verificá-las para que não fiquem erros. Estes erros podem ser de dois tipos: erros de edição, que é da própria estrutura que foi construída a planilha e erros de linguagem que trata da relação entre a linguagem lógica reconhecida pelo Excel e a linguagem matemática própria dos conteúdos.

                    Nesta postagem sugiro que o usuário faça testes para que se tenha confiabilidade no que a planilha retorna. Um leitor que acompanha o blog, costuma retornar suas opiniões sobre as planilhas e está sempre realizando testes (brincando) com elas [Prof. Edigley Alexandre do blog - TICs aliadas à Matemática]; inclusive em seu blog há uma boa coleção de planilhas eletrônicas que vale conferir!
                    Utilizo um mesmo conjunto de dados revesando os locais de entrada, ou seja, atribuindo as possíveis combinações de ordem para os dados de entrada, esse procedimento deverá retornar o mesmo resultado, pois a planilha foi construída para não depender de qual ponto ($P$, $Q$, $R$, $M$, ...) deve ser inserido primeiro, desde que estejam corretamente representados (no caso, os dados de entrada são vértices, abscissa ou ordenada e ponto médio). A seguir, apresento alguns dados que podem ser utilizados para a validação desta planilha:

                    [1] Calcular a distância entre os pontos:
                    • $P(-2,5)$, $Q(1,1)$, com resposta esperada: $5$
                    • $P(3,2)$, $Q(-1,4)$, com resposta esperada: $2\sqrt{5}\cong 4,472$
                    • $P(-3,1)$, $Q(5,-14)$, com resposta esperada: $17$
                    [2] Encontre a abscissa do ponto $P(x, 2)$, equidistante dos pontos $Q(3, 1)$ e $R(2, 4)$. Resposta esperada: $x=1$.

                    [3] Verifique se o triângulo $\Delta PQR$, de vértices $P(2, -2)$, $Q(-3, -1)$ e $R(1, 6)$, é isósceles. Resposta esperada: Sim, ele é isósceles, pois tem dois lados congruentes: $d(P,R) = d(Q,R) = \sqrt{65} \cong 8,062$ e $d(P,Q) = \sqrt{26} \cong 5,099$.

                    [4] Verifique se o triângulo formado pelos pontos $P(-1, -3)$, $Q(2, -5)$ e $R(6, 1)$ é retângulo. Resposta esperada: Sim, pois $d(P,R)=\sqrt{65}$, $d(P,Q)=\sqrt{13}$ e $d(Q,R)=\sqrt{52}$ e pelo Teorema de Pitágoras, a igualdade ${[d(P,R)]}^2 = {[d(P,Q)]}^2 + {[d(Q,R)]}^2$ é verdadeira.

                    [5] Determine o ponto médio $M$, dos segmentos:

                    • $P(-1, 4)$, $Q(5, 2)$, com resposta esperada: $M(2, 3)$.
                    • $P(\frac{1}{2}, 1)$, $Q(\frac{5}{2}, -4)$, com resposta esperada: $M(\frac{3}{2}, - \frac{3}{2})$.
                    [6] Tendo que o segmento formado pelos pontos $P(13, 19 )$ e $Q(x_1, y_1)$, possui como ponto médio $M(-9, 30)$, encontre as coordenadas do ponto $Q$. Resposta esperada: $Q(-31, 41)$.

                    [7] Os vértices de um triângulo são os pontos $P(-4, 2)$, $Q(0, 4)$ e $R(2, -6)$. Calcule os comprimentos das medianas do triângulo e o ponto em que as medianas se cruzam. Resposta esperada: Os pontos médios são $M_{PQ}= (-2, 3)$, $M_{PR}= (-1, -2)$ e $M_{QR}= (1, -1)$. As medianas são $d(M_{PR},Q) = \sqrt{37}$, $d(M_{PQ},R) = \sqrt{97}$ e $d(M_{QR},P) = \sqrt{34}$; com baricentro $B= (-\frac{2}{3}, 0)$.

                    Download


                    A planilha está disponível para download a partir dos servidores abaixo. Caso queira editar, implementar ou conferir algumas funções da planilha, a senha de desbloqueio é a sequência de 1 a 6.
                    • Arquivo originado em: Microsoft Office Excel 2010.

                    Google Drive
                    Google Drive
                    Box
                    Box

                    Referências

                    [1] GIOVANNI, José Ruy. Matemática Fundamental. Editora FTD. São Paulo, 1994.
                    [2] Distância Entre Dois Pontos no Plano. [Blog: O Baricentro da Mente]

                    Charles Bastos

                    Comente este artigo:

                    6 comentários:

                    1. Olá Charles, excelente material. Aliás, pelo que vejo por aí, o que você faz é singular. Explicar detalhadamente cada fórmula, cada passagem e disponibilizar o material para download, tenho certeza que que contribui sobremaneira para o aprendizado da matemática.

                      Um abraço.

                      ResponderExcluir
                      Respostas
                      1. Olá Kleber!

                        Muito obrigado pelo elogio. É bom saber que você gostou do material!

                        Acredito que sabendo utilizar tais recursos, eles contribuem para o aprendizado e para desmistificar os medos dados à Matemática.

                        Excluir
                    2. Olá, Charles!

                      Como já te disse antes, as suas planilhas são incríveis. As suas funcionalidades melhoram a cada nova planilha lançada. Não há desculpa hoje em dia para estudar e complementar os estudos com o uso de ferramentas com esta.

                      A facilidade não é a de apenas calcular valores, mas de fazer testes que dispensam o uso excessivo de papel e de escrita, o que pode se tornar cansativo as vezes.

                      As planilhas servem também como uma espécie de gabarito. Elas devem ser usadas para auxiliar nos estudos e não como um ferramenta que responde tudo com base numa pesquisa, e não há o raciocínio.

                      Um abraço!

                      ResponderExcluir
                      Respostas
                      1. Edigley!

                        Ter escolhido por divulgar um pouco do que faço, apesar do trabalho, tem sido gratificando,... Tenho aprendido muito com as pesquisas para o meu material e com as pessoas que vou conhecendo (como você).

                        Ótimo o seu comentário! Se os alunos de hoje valorizassem a quantidade de recursos que lhes é ofertado, teríamos alunos em um nível bem melhor...

                        Uma das utilidades destas planilhas é justamente o que você descreve, ser um recurso para testes, para perceber padrões/regularidades. Quanto a questão de ser uma ferramenta que oferta resposta direta, me preocupo em descrever o conteúdo relacionado na planilha... Como ela é usada, que a fará um recurso melhor (quase como, um aluno receber um trabalho, este trabalho valendo alguma nota; tirando a parte da nota, irá aprender mais aquele que se esforçou e não obteve nota máxima, que aquele que providenciou um trabalho pronto e obteve nota máxima). Quero dizer, o aluno/usuário que descaracteriza a finalidade pretendida com o recurso.

                        Obrigado por atentar-se aos conteúdos deste blog!

                        Excluir
                    3. Olá Charles :D

                      A cada dia que passa me surpreendo mais com seus artigos maninho. Parabéns pelo ótimo artigo e por esta maravilhosa planilha. Verei a possibilidade de passá-la para meus alunos do 2° ano como método de verificação de resultados, eles vão adorar tenho certeza...

                      Deu uma repaginada legal no blog em... Parabéns novamente. Você está aprendendo bastante sobre otimização e códigos html e css para blogs. O blog tem tudo para crescer exponencialmente daqui pra frente...

                      Att. Romirys Cavalcante

                      ResponderExcluir
                      Respostas
                      1. Olá Romiiii....

                        Pensa rapaz!

                        Tenho quase certeza que se não é você, o blog continuaria, mas sem tantas mudanças que tenho feito. Também tenho gostado de trabalhar um pouco mais no blog, apesar de não conhecer muito e de incomodá-los quase sempre.

                        Tomará que você utilize a planilha... Se utilizar, depois me passa um relato sobre como desenvolveu a atividade e sobre os resultados, quem sabe não temos mais uma postagem.

                        Estou pretendendo me tornar blogueiro mesmo. Tomará que dê certo. Eu não posso me cansar de agradecer você e tantos outros que estão colaborando para os meus registros na web.

                        Obrigado!

                        Excluir